Power365
Incident Report for Binary Tree
Resolved
Power365 services have returned to normal operations. Microsoft has confirmed resolution on the incident and has provided the following reference for an RCA when available - Tracking ID GVY5-TZZ
Posted Apr 02, 2021 - 02:05 UTC
Monitoring
Microsoft has mitigated the Azure DNS issue experienced. Power365 services are recovering.
Posted Apr 02, 2021 - 00:32 UTC
Investigating
Microsoft is reporting failures with Azure DNS. Operations teams are investigating any impact on Power365. Clients should refer to https://status.azure.com for the most up-to-date information on the status of Microsoft Azure Services.
Posted Apr 01, 2021 - 22:04 UTC
This incident affected: Power365: Platform (North America, Europe, Australia).