Power365 Platform - Admin Role Anomaly
Incident Report for Binary Tree
Resolved
After careful monitoring of results, this incident is resolved.
Posted Jan 16, 2021 - 15:34 UTC
Monitoring
Quest Engineering has implemented an emergency change and is monitoring the results.
Posted Jan 15, 2021 - 22:23 UTC
Identified
Quest Engineering has identified the cause of the anomaly and testing a change for emergency release.
Posted Jan 15, 2021 - 19:18 UTC
Investigating
Quest Engineering is investigating unexpected behavior where some admin roles are being removed from Power365 service accounts for a limited group of projects.
The investigation is ongoing and this page will be updated when more information is available.
Posted Jan 15, 2021 - 14:14 UTC